Forum - Index
Welcome to the WDTVFORUMS, Please register.

WD TV HD the media player by Western Digital plays almost any Movie format and Music format. Please take the time to register and show support as well as give support for all WD TV models. Use the link below to register and enjoy all the advantages of being a member, enter upcoming contests, see all the images and enjoy all the downloadable content the forum has to offer. Thank you and see you on the boards!

  • REGISTER HERE! (fast and free)

  • Welcome Guest ( Log In | Register )


    2 Pages V   1 2 >  
    Reply to this topicStart new topic
       Win7 Sharing fix that requires *NO* Registry Tweaks
    SiegeX
    post Dec 30 2009, 04:46 AM
    Post #1


    WDTV SEMI-PRO
    **

    Group: Members
    Posts: 17
    Joined: 30-December 09
    Member No.: 9,878




    So I just got the WDTV Live yesterday and I am running Win7 Pro x64 and I, like many of you, had no luck sharing folders with the WDTV Live. Some online searching popped up many people in various forums with the same problem. I've seen people suggest registry tweaking and turning on/off many advanced network settings. I just knew there had to be an easier way without all that, and luckily there is. The method detailed below uses no registry tweaks and it keeps all but one of the advanced network settings at their default value.

    Note: This method makes no guarantees with a tweaked registry, so if you did that, I suggest you undo it. I also have Homegroup Enabled. I don't know if this makes a difference or not.
    • Go to Control Panel --> Network and Sharing Center
    • Click on "Change advanced sharing settings" and use the following settings (most are default)
      • Turn on Network Discovery
      • Turn on File and Printer Sharing
      • Turn on Publish Folder Sharing
      • Turn on Media Streaming
      • Use 128-bit Encryption
      • Turn OFF password protected sharing
      • Allow Windows to manage homegroup connections
    • Right Click on the Folder you want to share
      • Click "Properties"
      • Go to the Sharing tab
      • Click on "Advanced Sharing"
      • Check "Share this folder"
      • Click "Apply" then "OK"
    • Click on "Share..." (this part makes it all work)
      • Type the username "Everyone" (can also use the dropdown list)
      • Click "Add"
      • Click "Share"
    • Click "Close"
    That's it for the Windows 7 side. As noted above, the magic that makes this all work is that you have to explicitly add the "Everyone" user to the share list. Just because the permissions menu has "Everyone" listed by default does not mean it is shared to them; ya I know, not very intuitive is it?

    Now lets setup the WDTV Live to logon to your share anonymously with no password.
    • Go to Settings --> Network setting
    • Turn ON "Auto login to network share"
    • Select "Clear login info for network share"
    Now browse to your Network Share and enjoy the movies!

    P.S. If this doesn't work, you can try the registry tweak mentioned here.

    Note:
    Windows Live ID Assistant is known to cause problems, so remove it as mentioned here.
    Microsoft Office Live Add-in might also possibly cause issues as mentioned here, so you can try removing that as well.
    Windows Live Essentials 2011 is also reported to cause problems with file shares as mentioned here, so you might want to keep away from this newer version for now (though apparently some people have managed to get Win7 and Live Essentials 2011 to co-exist).
    Go to the top of the page
     
    +Quote Post
    post Dec 30 2009, 04:46 AM
    Post #


    SITE SUPPORT


    Group: Bot

    Joined: Today, 08:10 PM




    Go to the top of the page
     
    Quote Post
    WDUser
    post Dec 30 2009, 06:28 AM
    Post #2


    WDTV GEEK
    Group Icon

    Group: Moderator
    Posts: 4,385
    Joined: 14-November 09
    Member No.: 6,287




    That's really cool SiegeX, thanks for sharing the info. here! (IMG:style_emoticons/default/cool.gif) Hope others with similar issues can confirm that it works as well for them.
    Go to the top of the page
     
    +Quote Post
    FuGGer
    post Dec 30 2009, 06:40 AM
    Post #3


    WDTV USER
    *

    Group: Members
    Posts: 6
    Joined: 27-November 09
    Member No.: 7,316




    i tried your method and it works when sharing a folder on my notebooks hard drive (VIDEOS).

    however, when i connected my 2tb mybook essential to my notebook (via usb) and tried to share a folder (MOVIES) from it i would get the no media found error on the wdtvl.

    i checked with another notebook running vista business to see if i could access the folder (MOVIES) on the 2tb mybook essential and it gave me an error. however, i could still access the share (VIDEOS) on my notebooks hard drive.

    Go to the top of the page
     
    +Quote Post
    Priit
    post Dec 30 2009, 10:50 AM
    Post #4


    WDTV SEMI-PRO
    **

    Group: Members
    Posts: 10
    Joined: 28-December 09
    Member No.: 9,755




    Never had a problem with sharing and it was done the exact same way you described. Still at some moment WD player stopped seeing network shares permanently...
    Go to the top of the page
     
    +Quote Post
    FuGGer
    post Dec 30 2009, 12:01 PM
    Post #5


    WDTV USER
    *

    Group: Members
    Posts: 6
    Joined: 27-November 09
    Member No.: 7,316




    ok everything works now...

    ive changed a few things on my notebook:-

    1) i have set a password for my account in win7 so now i have to enter a pwd everytime i start it up...
    the account i login into is the only account that is active on my notebook, guest account is turned off.

    2) i have turned off homegroup but it works even if it is on with my current settings. i tested it.

    3) below are my new settings, i am now able to see shares on my notebook hard drive as well as shares on my 2tb mybook essential connected to my notebook via usb.

    i use the username and password that i entered to login to win7 to access the shares thru wdtvl

    do all the changes on your pc/notebook. reboot.

    turn on your wdtvl, go to network settings and turn off auto login for now and clear the passwords. reboot. then look for your shares and enter your username/pwd to access it...

    (IMG:http://i5.photobucket.com/albums/y183/fuggers/AdvancedSharingSettings.jpg)
    Go to the top of the page
     
    +Quote Post
    SiegeX
    post Dec 30 2009, 05:32 PM
    Post #6


    WDTV SEMI-PRO
    **

    Group: Members
    Posts: 17
    Joined: 30-December 09
    Member No.: 9,878




    QUOTE (Priit @ Dec 30 2009, 07:50 AM) *
    Never had a problem with sharing and it was done the exact same way you described. Still at some moment WD player stopped seeing network shares permanently...

    I saw this same exact behavior yesterday. Out of nowhere for some reason the WDTV Live will error and fail to see my Notebook as an available computer with a network share. Power cycle (with remote) does not seem to change this. I havnt yet tried a reboot of Notebook + unplug WDTV Live but I suspect this will fix it. There definietly seems to be a networking bug in the .011 firmware; at least with respect to Win7.

    The easiest no-brainer fix I've found is to forego network shares altogether (for the time being) and use a DLNA media server; my current favorite is Serviio as it is entirely java based and has everything it needs included, the setup couldn't be simpler.
    Go to the top of the page
     
    +Quote Post
    Weioo
    post Jan 6 2010, 09:59 AM
    Post #7


    WDTV USER
    *

    Group: Members
    Posts: 7
    Joined: 5-January 10
    Member No.: 10,412




    The ONLY Thing that works for me to cure my "Invalid username or password" for the WDTV Live was the registry tweak. Everybody's system is different, but some people DEFINITELY need to use the registry tweak.

    I'm running Win7 Pro 64-bit, fresh install.

    The registry tweak is a legit solution. I avoided it for a long time because I wasnt sure what it did. Then I found it posted on some official microsoft forums, by an official microsoft tech and that calmed my nerves. Worked like a charm after that.
    Go to the top of the page
     
    +Quote Post
    SiegeX
    post Jan 6 2010, 04:56 PM
    Post #8


    WDTV SEMI-PRO
    **

    Group: Members
    Posts: 17
    Joined: 30-December 09
    Member No.: 9,878




    QUOTE (Weioo @ Jan 6 2010, 06:59 AM) *
    The ONLY Thing that works for me to cure my "Invalid username or password" for the WDTV Live was the registry tweak. Everybody's system is different, but some people DEFINITELY need to use the registry tweak.

    I'm running Win7 Pro 64-bit, fresh install.

    I'm running the same exact OS. You say you tried my method but you still got the invalid user/pass screen? This doesn't make any sense because my method does not use login info. Are you *sure* you followed every step, especially

    1) turning *OFF* passworded shares
    2) telling the WDTVL to forget previous login info
    3) telling the WDTVL to autologin with no name/pass
    4) Reverting the reg tweak if you already applied it

    I didn't quite know what the registry tweak did but now that I see it pertains to login info, it makes sense why my method works without it (since I don't use login). Now that I know the tweak is legit, I'd still rather use my method with no pass than tweak the reg because who knows what consequences it has on other devices. Also I fully expect WD to address this issue and make the reg tweak unnecessary at some point.

    P.S. Can you post the link to the MS knowledgebase article which you found the reg tweak at? I'd like to see if they give more info on what it does and why it's needed
    Go to the top of the page
     
    +Quote Post
    dhstraayer
    post Mar 22 2010, 04:00 PM
    Post #9


    WDTV USER
    *

    Group: Members
    Posts: 5
    Joined: 22-March 10
    Member No.: 15,413




    QUOTE (SiegeX @ Dec 30 2009, 02:46 AM) *
    So I just got the ... I also have Homegroup Enabled. I don't know if this makes a difference or not....

    I've tried the above, the registry tweaks, and everything else I could find. Still got the logon failure.

    Finally, I checked with WD support, and tried turning OFF the Win 7 Homegroup.

    That solved the problem.

    Now I'll start to back out some of those registry tweaks and other fixes that didn't work.

    DHS

    ----------

    I've found and fixed a couple of problems. Two biggies:

    1: the "Lost Network Connect" every 5-10 minutes problem.
    I have now resolved this issue with a workaround.

    I set the IP addresses of every computer on my network to fixed IPs in the range 192.168.0.23 ... 192.168.0.27.

    It takes a little care to set fixed IPs. If you're not sure, you might want to Google the topic.

    The router is, as usual 192.168.0.1, and I let the WD TV Live have its IP address assigned automatically.

    This appears to have fully resolved the "Lost Network Connection" bug, at least for me, for now.

    My best guess is that an IP collision occurred whenever a computer on the network tried to go out and check for new mail every 5 minutes. That's a somewhat wild guess, but the solution is working for me.
    2: the "Win 7 vs. Network Shares Logon Failure" bug.
    I just called WD tech support. After a little runaround about whether WD supported the live with Microsoft operating systems, he revealed the solution.

    Turn off Window 7 Homegroup. That's it. Control Panel/Network and Sharing Center/ Choose Homegroup and Sharing Options/"leave the homegroup".

    I did this, and now "Media Servers / Streaming" now no longer works. I don't care, because you can't play ripped VOBs from Streaming. I can now access everything I want through Network Shares.

    Maybe sometime in the future WD will release a firmware upgrade that is compatible with Win 7 Homegroup. That would be nice.

    But it sure was hard to find out about turning off the Homegroup feature.

    By the way, it may still be necessary to make sure your workgroup is named "WORKGROUP". I'm not sure, as I already reverted to the "WORKGROUP" name.
    Reason for edit: Added useful info. posted in dhstraayer's introduction, which is sure to be missed by people looking for fixes here
    Go to the top of the page
     
    +Quote Post
    jjbennee
    post Mar 28 2010, 04:11 PM
    Post #10


    WDTV USER
    *

    Group: Members
    Posts: 1
    Joined: 26-March 10
    Member No.: 15,627




    After following everything here... alone with the registry tweaks, I was still get bad connection errors. One thing that I have noticed. When WDTVLIVE is off and then turned on then it takes a while to connect to the network shares. Once the Windows 7 is rebooted WHILE WDTVLIVE is on then the shares come up fine. I noticed that the powersave functions are on which allows the HDD's to turn off after 30min and enables the windows 7 computer to go into sleep mode. This is set by default by microsoft.

    Set the Windows 7 computer to high performance and it shouldn't drop anymore and WDTVLIVE should find it without any problems. (This is after all the proper sharing was done along with the registry hacks followed in this forum)
    Go to the top of the page
     
    +Quote Post
    Jim in SAC
    post May 31 2010, 04:57 PM
    Post #11


    WDTV USER
    *

    Group: Members
    Posts: 2
    Joined: 11-March 10
    Member No.: 14,664




    I have no idea WHY, but I found what totally screwed up my network sharing. A few days ago, I changed my default DNS server on my network DHCP settings from my default ISP DNS (Comcast) to OpenDNS (208.67.222.222). I didn't realize it at the time, but for some reason it totally hosed my ability to access network shares on my Windows 7 PC from my WDTV Live box, my XBox 360 and my PS3. I could only access files shared via Media Center but had trouble playing most files. I spend two days changing out CODECS, turning off Firewall settings, Antivirus settings removing and re installing shares. Then I remembered changing DSN servers. I though NO WAY, but... Well the within minutes of switching back to the default DNS servers for my ISP, all the shares came back up and all is well.

    I have NO clue why using OpenDNS would cause this problem, but I now want to find out just what OpenDNS does.

    If you are having trouble with your network shared and you are using OpenDNS, try going back to your ISP DNS servers to see if it fixes the problem like it did for me.
    Go to the top of the page
     
    +Quote Post
    jac134
    post Jul 1 2010, 02:43 AM
    Post #12


    WDTV USER
    *

    Group: Members
    Posts: 7
    Joined: 29-June 10
    Member No.: 21,331




    Hi there,

    I had no end of troubles getting network sharing working. If you have all the network sharing set correctly under advanced network settings.
    try this, its simple and it worked

    Delete windows live id assistant on your computer through the control panel, and then delete the saved login info from the wd live in the settings. Also set the wd to not ask for a password (auto login), and bingo!!!

    I srtuggled for a week to get this to work. countless hours of frustration, until I found this suggestion in an obscure forum.

    Cheers
    Go to the top of the page
     
    +Quote Post
    99k1500
    post Jul 1 2010, 04:37 PM
    Post #13


    WDTV USER
    *

    Group: Members
    Posts: 1
    Joined: 1-July 10
    Member No.: 21,453




    Uninstalling the Windows live sign in assistant. Also worked for me...

    Network was working then stopped. I should have thought about windows updates, but I didn't.

    WD TV Live Plus
    Win 7 64 bit
    Go to the top of the page
     
    +Quote Post
    WDUser
    post Jul 2 2010, 11:21 AM
    Post #14


    WDTV GEEK
    Group Icon

    Group: Moderator
    Posts: 4,385
    Joined: 14-November 09
    Member No.: 6,287




    Hmm jac, sure looks like you're on to something here! (IMG:style_emoticons/default/smile.gif)
    Go to the top of the page
     
    +Quote Post
    n0b0dy2
    post Aug 10 2010, 12:19 PM
    Post #15


    WDTV USER
    *

    Group: Members
    Posts: 1
    Joined: 10-August 10
    Member No.: 23,621




    Also works for me in win 7 64b
    Go to the top of the page
     
    +Quote Post
    ismav
    post Aug 14 2010, 02:18 PM
    Post #16


    WDTV USER
    *

    Group: Members
    Posts: 1
    Joined: 14-August 10
    Member No.: 23,842




    Thanks Smi-Pro... it worked
    Reason for edit: No need to quote the entire original post for a simple thanks. :)
    Go to the top of the page
     
    +Quote Post
    chuckisgreat
    post Sep 16 2010, 09:28 PM
    Post #17


    WDTV SEMI-PRO
    **

    Group: Members
    Posts: 23
    Joined: 21-January 10
    Member No.: 11,546




    Didn't work for me. I had to use the registry tweak. For those wondering what on earth that is and the Win7 Advanced Network Settings that I had to use, see here: http://wdtvhd.com/index.php?showtopic=1680...ost&p=32194
    Go to the top of the page
     
    +Quote Post
    onyxatom
    post Sep 18 2010, 05:20 PM
    Post #18


    WDTV SEMI-PRO
    **

    Group: Members
    Posts: 10
    Joined: 23-April 10
    Member No.: 17,400




    I think it should be mentioned that if the WD still does not see the network shares you should try specifying a different workgroup than the sharing PC. That is what turned out to me my problem.
    Go to the top of the page
     
    +Quote Post
    jjbinks
    post Oct 20 2010, 10:48 AM
    Post #19


    WDTV USER
    *

    Group: Members
    Posts: 2
    Joined: 10-October 10
    Member No.: 27,710




    I have problem with streaming .mkv files from sharing, but shared folders are on PC with Windows 7. After while screen is tearing and no sound. How is solution for me, I dont know to find any "DDE" options in Windows 7 settings. Thanx for your answers.
    Go to the top of the page
     
    +Quote Post
    Rev Drew
    post Oct 20 2010, 03:36 PM
    Post #20


    Global Moderator
    Group Icon

    Group: Global Mod :: Site Supporter
    Posts: 2,433
    Joined: 4-April 09
    From: Canada eh?
    Member No.: 10




    depends, are you streaming 720p content when that happens or 1080p?

    720p should work fine with windows sharing, 1080p will require the use of NFS (see here for more on how to configure NFS on Win7).
    Go to the top of the page
     
    +Quote Post

    2 Pages V   1 2 >
    Reply to this topicStart new topic
    1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
    0 Members:

     

    Lo-Fi Version
    Delete cookies set by this board · Mark all posts as read
    Time is now: 20th October 2014 - 08:10 PM