Forum - Index
Welcome to the WDTVFORUMS, Please register.

WD TV HD the media player by Western Digital plays almost any Movie format and Music format. Please take the time to register and show support as well as give support for all WD TV models. Use the link below to register and enjoy all the advantages of being a member, enter upcoming contests, see all the images and enjoy all the downloadable content the forum has to offer. Thank you and see you on the boards!

  • REGISTER HERE! (fast and free)

  • Welcome Guest ( Log In | Register )


     
    Reply to this topicStart new topic
       No audio on mkv2rls files, audio problems
    discostew10
    post Aug 3 2010, 06:14 AM
    Post #1


    WDTV USER
    *

    Group: Members
    Posts: 2
    Joined: 2-August 10
    Member No.: 23,185




    Hi Guys,

    just curious if anyone else has this issue. i have 4 mkv files that, when checked with media info, say they were put together with mkv2rls. none of them play audio. Ive read on this forum about similar issues with a new header or something that mkvmerge uses when compiling the files. Anyone know if this is the same type of thing? any fixes? i tried remuxing using mkvmerge, but then all hell broke loose. after i tried to play the remuxed file all i got was a black screen...then any other file i already had on my external HD did the same. so i had to reset the WD HDTV (v1) back to factory defaults....weird.

    any ideas?
    thanks all.
    Go to the top of the page
     
    +Quote Post
    post Aug 3 2010, 06:14 AM
    Post #


    SITE SUPPORT


    Group: Bot

    Joined: Today, 04:53 AM




    Go to the top of the page
     
    Quote Post
    WDUser
    post Aug 3 2010, 02:17 PM
    Post #2


    WDTV GEEK
    Group Icon

    Group: Moderator
    Posts: 4,394
    Joined: 14-November 09
    Member No.: 6,287




    While remuxing, what did you do exactly? All you need to do for every audio track is to set header compression to None. This should not affect the video at all, so if the video was visible on the Gen. 1 earlier, it should remain so even after remuxing to fix the audio.
    Go to the top of the page
     
    +Quote Post
    discostew10
    post Aug 6 2010, 07:11 PM
    Post #3


    WDTV USER
    *

    Group: Members
    Posts: 2
    Joined: 2-August 10
    Member No.: 23,185




    i added the file
    clicked the audio track under 'tracks, chapters and tags'
    clicked the 'extra options' tab
    set the compression drop down to 'none'
    hit the 'start muxing' button

    seemed pretty straight forward but then the file buggered up my media player. the file played fine on my PC
    Go to the top of the page
     
    +Quote Post
    WDUser
    post Aug 7 2010, 09:16 AM
    Post #4


    WDTV GEEK
    Group Icon

    Group: Moderator
    Posts: 4,394
    Joined: 14-November 09
    Member No.: 6,287




    Try with mkvtoolnix 3.x instead and see if that helps.

    You can also check out mkWDclean from here.
    Go to the top of the page
     
    +Quote Post
    wforceduser
    post Aug 19 2010, 07:29 PM
    Post #5


    WDTV PRO
    ***

    Group: Members
    Posts: 40
    Joined: 10-July 09
    Member No.: 965




    Doesn't the new version of mkvmerge set compression as default on both audio AND video - ie, you must go into both tracks and set it to none (rumor has it WD are working on a fix for the next firmware)
    Go to the top of the page
     
    +Quote Post
    mcwuppy
    post Aug 20 2010, 01:42 PM
    Post #6


    WDTV SEMI-PRO
    **

    Group: Members
    Posts: 21
    Joined: 8-May 09
    Member No.: 155




    you have to select and highlight the Audio track, go to extra options tab and set it to NONE (just like you did)
    BUT YOU ALSO HAVE TO select and highlight the Video track, go to extra options tab and set it to NONE aswell.
    Go to the top of the page
     
    +Quote Post
    jimtryon
    post Aug 22 2010, 10:21 PM
    Post #7


    WDTV USER
    *

    Group: Members
    Posts: 8
    Joined: 6-June 09
    Member No.: 467




    I had near the same problem, but using mkWDclean. After "cleaning" an mkv file with it, the WD Live player couldn't play it at all. It sat there spinning a graphic "working" wheel untill I escaped out. Then all the previously fine video files also behaved the same way. I put it right by resetting to factory defaults. I was persistant and re-did this several times with the same result, using different mkv files. It is as if this utility contains a sabatage attack for the WDTV player. By the way, while it is "cleaning" a file, it puts a rightious admonition on screen, that the user should repair the faulty player, not a perfectly good mkv file.
    Go to the top of the page
     
    +Quote Post
    WDUser
    post Aug 23 2010, 04:56 PM
    Post #8


    WDTV GEEK
    Group Icon

    Group: Moderator
    Posts: 4,394
    Joined: 14-November 09
    Member No.: 6,287




    QUOTE (jimtryon @ Aug 23 2010, 08:51 AM) *
    By the way, while it is "cleaning" a file, it puts a rightious admonition on screen, that the user should repair the faulty player, not a perfectly good mkv file.

    As if it's up to the user to do so. (IMG:style_emoticons/default/rolleyes.gif)
    Go to the top of the page
     
    +Quote Post
    jimmyjazzz
    post Jul 20 2011, 11:17 AM
    Post #9


    WDTV USER
    *

    Group: Members
    Posts: 2
    Joined: 20-July 11
    Member No.: 70,435




    Folks,

    Some P2P Groups, IMMERSE being the main culprits, use the mkv2rls writing application when muxing their files. Files written with mkv2rls are now notorious for having audio problems. The reason for the problem stems from an apparent default "audio sampling frequency" setting of "0". This setting needs to be changed to the correct setting before the file can work properly.

    Running your .mkv file through MediaInfo will show the proper audio sampling frequency.

    MediaInfo example:

    Audio
    ID : 2
    Format : AC-3
    Format/Info : Audio Coding 3
    Mode extension : CM (complete main)
    Codec ID : A_AC3
    Duration : 51mn 36s
    Bit rate mode : Constant
    Bit rate : 384 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Bit depth : 16 bits
    Compression mode : Lossy
    Stream size : 142 MiB (10%)
    Title : English
    Language : English

    To change the audio sampling frequency to the correct setting, we will use the MKVMerge (mkvmerge GUI) software. The latest build is mkvmerge GUI v4.9.1

    You can get it here: http://www.bunkus.org/videotools/mkvtoolnix/downloads.html

    Once downloaded, install the MKVMerge software by opening the mkvtoolnix-unicode-4.9.1-setup.exe (there's a portable version available as well that requires no installation).

    When you're asked if you want a shortcut placed on your desktop, click "Yes". You can always move it to where you want later.

    Once installed:

    1) Open MKVMerge (mkverge GUI)
    2) Click on "File" (top left hand corner)
    3) Click on "Header editor"
    4) In the "Header editor" window, click on "File" once again
    5) Click on "Open" to find/choose the IMMERSE .mkv file (it could take a few seconds to open)
    6) Once it opens, click on the "+" just to the left of "Audio track 2"
    7) In the drop-down menu, highlight "Audio sampling frequency"
    8) In the window to the right, change the "current value" from 0 to 48000
    9) Click on "File" again
    10) Click on "Save" (it could take a few seconds to save)
    11) Click on "Quit"
    12) Close MKVMerge (mkverge GUI)

    **If, for some reason, the file still does not play after applying the fix, you can try remuxing it**

    How to remux a file with MKVMerge:

    1) Open MKVMerge (mkvmerge GUI)
    2) Click on "Add" to find your file.
    3) In the "Tracks, chapters and tags" box, highlight the first line (V_MPEG4/ISO...)
    4) After highlighting the line, click on the "Extra options" tab just below.
    5) On the "Compression" line, open the drop down menu and make sure "None" is entered. This is very important.
    6) In the "Tracks, chapters and tags" box, highlight the second line (A_AC3...)
    7) Follow steps 4-5 again
    8) The new file will be in the same directory as the original file, but will now have a (1) appended to the file name.
    9) Click on "Start muxing", found at bottom left.

    The muxing should take between 5-30 minutes max., depending on your computer. If you need to, disable any other CPU-intensive applications during this time -- the muxing will go faster.

    Hope this helps.

    JJ
    Reason for edit: Changed download link to official site, and mentioned portable version
    Go to the top of the page
     
    +Quote Post

    Reply to this topicStart new topic
    1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
    0 Members:

     

    Lo-Fi Version
    Delete cookies set by this board · Mark all posts as read
    Time is now: 23rd November 2014 - 04:53 AM