Forum - Index
Welcome to the WDTVFORUMS, Please register.

WD TV HD the media player by Western Digital plays almost any Movie format and Music format. Please take the time to register and show support as well as give support for all WD TV models. Use the link below to register and enjoy all the advantages of being a member, enter upcoming contests, see all the images and enjoy all the downloadable content the forum has to offer. Thank you and see you on the boards!

  • REGISTER HERE! (fast and free)

  • Welcome Guest ( Log In | Register )


     
    Reply to this topicStart new topic
       Defective Passport connector
    Cal
    post Nov 7 2011, 05:46 PM
    Post #1


    WDTV USER
    *

    Group: Members
    Posts: 2
    Joined: 5-February 10
    Member No.: 12,383




    Hi,

    The usb connector to My Passport is defective. The cable doesn't want to plug in.

    Can this connector be replaced/repaired?

    I'm a little leery purchasing another Passport to operate my WD TV Live. Will any external HD work?

    Thanks,
    Cal
    Go to the top of the page
     
    +Quote Post
    post Nov 7 2011, 05:46 PM
    Post #


    SITE SUPPORT


    Group: Bot

    Joined: Today, 12:59 AM




    Go to the top of the page
     
    Quote Post
    Rev Drew
    post Nov 7 2011, 08:20 PM
    Post #2


    Global Moderator
    Group Icon

    Group: Global Mod :: Site Supporter
    Posts: 2,374
    Joined: 4-April 09
    From: Canada eh?
    Member No.: 10




    no idea, you had better ask WD directly, pictures would be helpful to them as well I'm sure.
    Go to the top of the page
     
    +Quote Post
    Cal
    post Nov 9 2011, 06:48 PM
    Post #3


    WDTV USER
    *

    Group: Members
    Posts: 2
    Joined: 5-February 10
    Member No.: 12,383




    I contacted WD. They sent me a new Passport.
    (IMG:style_emoticons/default/smile.gif)
    Go to the top of the page
     
    +Quote Post
    Rev Drew
    post Nov 9 2011, 08:39 PM
    Post #4


    Global Moderator
    Group Icon

    Group: Global Mod :: Site Supporter
    Posts: 2,374
    Joined: 4-April 09
    From: Canada eh?
    Member No.: 10




    perfect, I hope you didn't lose to much data on it.
    Go to the top of the page
     
    +Quote Post

    Reply to this topicStart new topic
    1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
    0 Members:

     

    Lo-Fi Version
    Delete cookies set by this board · Mark all posts as read
    Time is now: 25th April 2014 - 12:59 AM