Forum - Index
Welcome to the WDTVFORUMS, Please register.

WD TV HD the media player by Western Digital plays almost any Movie format and Music format. Please take the time to register and show support as well as give support for all WD TV models. Use the link below to register and enjoy all the advantages of being a member, enter upcoming contests, see all the images and enjoy all the downloadable content the forum has to offer. Thank you and see you on the boards!

  • REGISTER HERE! (fast and free)

  • Welcome Guest ( Log In | Register )


     
    Reply to this topicStart new topic
       WDTV Live Plus not booting
    Punchi
    post Mar 21 2012, 05:45 PM
    Post #1


    WDTV USER
    *

    Group: Members
    Posts: 1
    Joined: 15-March 12
    Member No.: 108,866




    Hello to ALL WDTV Forum,

    Well I have the present problem. My Live Plus won't BOOT, and I think I tryed about everything (FW, AC Adapter, etc., etc.). I found a video in Youtube that shows my exact same problem, and any help will e highly appreciated as my device is out of warranty. The video link is:



    Thanks again!
    Go to the top of the page
     
    +Quote Post
    post Mar 21 2012, 05:45 PM
    Post #


    SITE SUPPORT


    Group: Bot

    Joined: Today, 10:57 AM




    Go to the top of the page
     
    Quote Post
    WDUser
    post Mar 22 2012, 05:28 AM
    Post #2


    WDTV GEEK
    Group Icon

    Group: Moderator
    Posts: 4,370
    Joined: 14-November 09
    Member No.: 6,287




    Have you tried different cables (HDMI/composite/component) to rule out a connection problem?

    Have you tried the hard reset button?

    Also try inserting a FAT32-formatted USB stick with the latest firmware files on it (you might need to edit the version number in the .VER file as mentioned in the Tutorials section), then boot the player by inserting the power cord. If all goes well, it should enter auto-update mode and start the FW flash process.

    If nothing works and you've got a dead device on your hands, it's still worth a try asking WD about an exchange or maybe getting it repaired if possible.
    Go to the top of the page
     
    +Quote Post

    Reply to this topicStart new topic
    1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
    0 Members:

     

    Lo-Fi Version
    Delete cookies set by this board · Mark all posts as read
    Time is now: 27th August 2014 - 10:57 AM